top of page

LAB 1 : Basic Configuring Cisco Router (IPv4) - CCNA

โจทย์ : จาก Network Diagram ทำการตั้งค่าบน Router ตามหัวข้อดังต่อไปนี้



1. Hostname : R1

2. Enable password :1234

3. Enable secret : cisco

4. Banner Motd :

5. Line console 0 : password cisco

6. IP Address Interface G0/0 : 10.10.10.1/30 , Interface G0/1 : 172.29.16.1/24

7. Username/Password Configuration

username admin privilege 15 password cisco

8. Telnet Configuration

Line vty 0 4 : password cisco

9. SSH Configuration

10. save Configuration


ดู Video :


Download ไฟล์ LAB คลิกด้านล่างนี้ :

#LAB 1 BASIC CONFIGURING CISCO ROUTER (I
.
Download • 109KB


Network Diagram :




Task and Configuration

1. ตั้งค่า Hostname

ทำการ Check Pre-Configuration ของ R1

เข้าสู่โหมด Privilege

Router>enable

เข้าสู่โหมด Configuration

Router#configure terminal

เปลี่ยนชื่อของ Router เป็น “R1”

Router(config)#hostname R1

ออกจากโหมด Configuration

R1(config)#exit

ทำการตรวจสอบ Confiuration โดยการใช้คำสั่ง “show running-config” (Hostname จะเปลี่ยนแปรงทันที ที่ Enter command)

R1#show running-config
------ตัดข้อความบางส่วน-------------------
hostname R1

2. ตั้งค่า Enable Password

เข้าสู่โหมด Configuration

R1#configure terminal

ตั้ง Password ก่อนเข้าสู่โหมด Privilege (ไม่เข้ารหัส)

R1(config)#enable password 1234

ออกจากโหมด Configuration

R1(config)#exit

ทำการตรวจสอบ Configuration โดยใช้คำสั่ง “show running-config” และทดสอบเข้าสู่โหมด Privilege ใส่ Enable Password (1234) ที่ได้ทำการตั้งค่าไว้

R1#show running-config
------ตัดข้อความบางส่วน------------------- 
enable password 1234


3. ตั้งค่า Enable Secret

เข้าสู่โหมด Configuration

R1#configure terminal

ตั้ง Password ก่อนเข้าสู่โหมด Privilege (มีการเข้ารหัส)

R1(config)#enable secret cisco

ออกจากโหมด Configuration

R1(config)#exit

ทำการตรวจสอบ Configuration โดยใช้คำสั่ง “show running-config” และทดสอบเข้าสู่โหมด Privilege ใส่ Enable Secret Password (cisco)ที่ได้ทำการตั้งค่าไว้

R1#show running-config
------ตัดข้อความบางส่วน-------------------
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0 


4. ตั้งค่า Banner Motd

ตั่งค่า Banner ก่อนเข้า Router โดยตัวอักษรสัญลักษณ์ ^ เป็นสัญลักษณ์เพื่อบอกให้ทราบว่าเป็นตัวเริ่มต้นและปิดท้ายของข้อความ

R1(config)#banner motd ^
^

ใช้สัญลักษณ์ ^ ปิดท้ายข้อความ


ทำการตรวจสอบ Configuration โดยใช้คำสั่ง “show running-config” และ ทดสอบ Logout และ Login ใหม่อีกครั้ง แล้วสังเกตุ Banner ที่แสดงขึ้นมา

R1#show running-config
------ตัดข้อความบางส่วน-------------------
#banner motd 

^

5. ตั้งค่า Line console 0 Password

ตั้งค่า Password ก่อนเข้า Router ผ่าน Port Console

R1(config)#line console 0

ตั้งค่า Password

R1(config-line)#password cisco

ตั้งค่าให้มีการ login แล้วถาม Password ที่ตั้งไว้

R1(config-line)#login

ออกจากโหมด Configuration (ใช้ “end”จะกลับมาสู่ โหมด Enable)

R1(config-line)#end

ทำการตรวจสอบ Configuration โดยใช้คำสั่ง “show running-config” และ ทดสอบ Login ผ่านสาย Console แล้วใส่ Password ที่ได้ทำการตั้งค่าไว้

R1#show running-config
------ตัดข้อความบางส่วน-------------------
line con 0
password cisco
login


6. ตั้งค่า IP Address

เข้าสู่โหมด Interface

R1(config)#interface GigabitEthernet0/0

ตั้งค่า IP Address บน Interface

R1(config-if)#ip address 10.10.10.1 255.255.255.252

เปิด Interface ให้ทำงาน

R1(config-if)#no shutdown

ออกจากโหมด Configuration

R1(config-if)#exit

เข้าสู่โหมด Interface

R1(config)#interface GigabitEthernet0/1

ตั้งค่า IP Address บน Interface

R1(config-if)#ip address 172.29.16.1 255.255.255.0

เปิด Interface ให้ทำงาน

R1(config-if)#no shutdown

ออกจากโหมด Configuration (ใช้ “end”จะกลับมาสู่ โหมด Enable)

R1(config-if)#end

ทำการตรวจสอบ Status ของ Interface โดยการใช้คำสั่ง “show ip interface brief” ก็จะแสดง IP Address และ Status เป็น UP UP ทั้ง 2 Interface (หากต้องการดู Configuration ก็ให้ใช้คำสั่ง “show running-config” เช่นเดิม )

R1#show ip interface brief 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 10.10.10.1 YES manual up up
GigabitEthernet0/1 172.29.16.1 YES manual up up

7. ตั้งค่า Username/Password

ตั้งค่า Username และ Password ใน Router (Local)

R1(config)#username admin privilege 15 password cisco

ตรวจสอบ Username/Password Local ที่ตั้งค่า

R1#show running-config
------ตัดข้อความบางส่วน-------------------
username admin privilege 15 password 0 cisco 

8. ตั้งค่า Telnet

ตั้งค่า line vty 0 4 (ให้มีการ Access โดยการ Remote จากระยะไกลเข้ามาตั้งแต่ line 0-4)

R1(config)#line vty 0 4

เรียกใช้ Username/Passwrod ที่เป็น Local ในการ login (จะไม่สนใจ Password ที่อยู่ภายใต้ line vty 0 4)

R1(config-line)#login local 

หรือ เราสามารถตั้งค่าให้เรียกใช้ หรือ Authentication ด้วย password ภายใต้ line vty ก็ได้ ดังตัวอย่างต่อไปนี้

R1(config)#line vty 0 4

ตั้งค่า Password ใน Line vty จะเรียกใช้ Password ที่อยู่ใน Line vty ในการ login (ต้องตั้งค่า Enable Password ด้วย)

R1(config-line)#password cisco

ตั้งค่าให้มีการ Login ด้วยรหัสผ่าน

R1(config-line)##login

ทดสอบ Telnet เข้า Router “R1”จาก PC

PC>telnet 172.29.16.1
Trying 172.29.16.1 ...Open

9. ตั้งค่า SSH

ตั้งค่าการ Remote เข้ามาโดยการใช้ SSH เริ่มจากการตั้งค่า domain-name

R1(config)#ip domain-name ninehua.com

Generate Key เพื่อเข้ารหัส

R1(config)#crypto key generate rsa 

ขนาดของ Key (ขั้นต่ำสำหรับ ssh version 2)

เลือกใช้ Secure shell Version 2

R1(config)#ip ssh version 2

ทดสอบ SSH เข้า Router “R1”จาก PC

PC>ssh -l admin 172.29.16.1
Open
Password:

10. Save configuration

ทำการ Save Configuration ที่อยู่ใน RAM ไปไว้ที่ NVRAM (Copy config ที่กำลังทำงานอยู่ไปเก็บใน NVRAM)

R1#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]

ทำการตรวจสอบ Configuration ที่ทำการ save ไว้ด้วยคำสั่ง “show startup-config”

R1#show startup-config 
Using 728 bytes
version 15.1
------ตัดข้อความบางส่วน------------------- 

ดู 4,068 ครั้ง1 ความคิดเห็น

1 Comment

Rated 0 out of 5 stars.
No ratings yet

Add a rating

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 10.10.10.1 YES manual up down

GigabitEthernet0/1 172.29.16.1 YES manual up up

สาเหตุที่ 0/0 10.10.10.1 Protocol Down เกิดจากอะไรครั


Like
bottom of page